感谢各位帮助,顺手写了个一键安装脚本
← 返回列表

当前位置: 作者:2077朋克 · 2026-06-04 11:52:36

#1 2077朋克 · 2026-06-04 11:52:36
stalltrix

感谢各位大佬帮助,我大概研究出正确解法了。



记录一下,顺便写了一个一键安装脚本。

https://github.com/ubtolan/kepinstall

小白摸索出来写的脚本,大佬不要笑哈。




之前的帖子我回不了,程序重启后我这边帖子确认全消失了。只能重新发一个帖子。应该是卡bug的副作用、




[
之前发的部署教程的帖子](https://meta.stalltrix.com/index.php?topic=12fd89c953feba6b5055db5a0f57b800a3f99d456cebfe837a9296abf8457636),我靠感觉搞出来的,让各位笑话了,还好各位大佬挺热心的,详细指点了我的错误。还给了改进建议。

这次再搞了一版,在各位大佬的帮助,搞了一个应该可以完整运行的节点了。应该不是卡bug的部署方式了。把我的部署经验顺手写了一个脚本,这次再详细介绍一下

脚本很简单



```bash
wget https://raw.githubusercontent.com/ubtolan/kepinstall/refs/heads/main/kepinstall.sh
bash kepinstall.sh
```

然后会人输入配置,



安装完成后就会显示这个











我介绍一下这些参数的关联









注意一点



验证域名是下面挂TXT记录的域名,不是webui访问域名,可以参考为[
之前发的这个的帖子](https://meta.stalltrix.com/index.php?topic=12fd89c953feba6b5055db5a0f57b800a3f99d456cebfe837a9296abf8457636)

<Br>

功能



我的这个脚本实现webui与edge程序的二合一,token管理页面的"本地URL"只需要填写webui地址即可。


如果是直接用,记得把ca.crt与ca.key换成自己的ssl证书,默认是自签名ssl证书。




2.套cloudflare cdn



我的这个脚本部署完后,还能给webui直接套cf

下面说下怎么套cf



添加一个A记录到服务器上就行了。如果是v6的话,应该是用AAAA。

然后直接访问webui地址就行了。




脚本默认使用的是443端口,如果你改成了8443或者其他端口,要设置一个源重写规则




注意流程



apply申请了token -> 把token填入脚本部署 -> 套cf -> 回到token页面,填写自己的webui地址。




这个时候应该能保存成功,而不会提示失败





~~顺便研究了下这里的其他功能,把头像与名字也设置上去了。之前没有设置名字,会直接显示域名,总感觉怪怪的~~

#2 星河 · 2026-06-04 11:58:17
stalltrix

> 之前的帖子我回不了,程序重启后我这边帖子确认全消失了。

其实是能回复的,回复不了只是webui没有这个指针而已。webui只能回复已保存指针的帖子。

其实你使用cli 手动指定 topic hash就能直接回复了。
#3 kanshan · 2026-06-05 01:38:03
stalltrix
其实并不一定需要cli,webui也能卡bug把回帖指针卡出来,从而实现虚空回帖。不一定真的保存有原始指针帖子

这里有一个创设区块`d9329b038c59e8393a9fcc875461fd3665e8fc5f770efb8b6eee046eb6765d66`是第一个帖子,其实没啥用。但是可以拿来卡bug。

比如你想卡出你上一个帖子`12fd89c953feba6b5055db5a0f57b800a3f99d456cebfe837a9296abf8457636`的引用,从而实现虚空回复。

只需找到`d9329b038c59e8393a9fcc875461fd3665e8fc5f770efb8b6eee046eb6765d66.mdb`,复制为`12fd89c953feba6b5055db5a0f57b800a3f99d456cebfe837a9296abf8457636.mdb`,放到`kep-data/0`中,然后打开`kep-data/tag_0.idx`,写入`12fd89c953feba6b5055db5a0f57b800a3f99d456cebfe837a9296abf8457636\n`这个值(声称拥有这个帖子)。




然后重启webui,就能卡出bug了。打开`index.php?topic=12fd89c953feba6b5055db5a0f57b800a3f99d456cebfe837a9296abf8457636`,直接回复。就能虚空写入。

这个其实也是一个bug,但是需要操作硬盘,并且只影响自己的的webui。应该变成了特性
#4 2077朋克 · 2026-06-05 01:59:38
stalltrix
感谢大佬回复,cli我不太会用,我按照大佬的webui方法卡bug,写入了索引,但是会报错

```
[level=1]
12fd89c953feba6b5055db5a0f57b800a3f99d456cebfe837a9296abf845763 format hex err: encoding/hex: invalid byte: U+000A
```

并且已有的正常帖子反而还会消失,这种是怎么回事,卡bug失败了吗。
#5 kanshan · 2026-06-05 02:07:27
stalltrix
@2077朋克(nqcpjw) 不是,检查一下你索引是否损坏。可以用

```
./kep-cli-linux-amd64 -act chk
```

还有注意一点,写入的索引是`{hash}\n`,注意后面有一个换行符。而直接写入`{hash}`会导致偏移损坏。

还有如果在Windows下,容易写入为`{hash}\r\n`,多了一个\r这种也会导致偏移损坏。我以前就提过这个问题,可以看我以前发的帖子
#6 2077朋克 · 2026-06-05 02:15:34
stalltrix
卧槽大佬神医,果然是没注意\n索引被写坏的问题。

试了下,虚空回复成功了。哈哈哈

#7 刘邦 · 2026-06-05 05:04:49
stalltrix
楼主建议改一下证书生成逻辑 `-subj "/CN=$DOMAIN"`。$DOMAIN这里是验证域名,而非webui域名。虽然不影响逻辑。

验证域名是直接展示在前台的、

如果webui使用验证域名的common name,容易被censys之类的扫出来。
#8 2077朋克 · 2026-06-06 09:04:48
stalltrix
@刘邦(dexbir) 感谢大佬提醒,这个泄露问题改了。

#9 下耕 · 2026-07-05 05:22:35
stalltrix
大佬,论坛上游程序更新了哦,能不能把你脚本也更新下
#10 2077朋克 · 2026-07-05 11:44:44
stalltrix
@下耕(yw6qcv) 我现在已经迁移到worker上面了,没用这套程序了。

可以看看这个worker版本,挺好用的
#11 2077朋克 · 2026-07-28 09:08:32
stalltrix
@下耕(yw6qcv) 还是抽空更新了下脚本,升级了最新版依赖。移除了安装时强制要求填写邻居token(这个可以后续自行在webui上设置)

注册

或使用第三方注册

登录

没有账号? 立即注册
技术
闲聊
开发
正在提交...